NetDocuments Restore: Documents have Result_Ids but are not visible / searchable in NetDocuments

NetDocuments Restore: Documents have Result_Ids but are not visible / searchable in NetDocuments

ISSUE:

You appear to have successfully completed a migration into NetDocuments because all documents have a Result_Id and no error message.  However, the documents are not visible or searchable in NetDocuments.

CAUSE:

The NetDocuments web interface does not list documents with no valid versions.
While the documents may have been successfully created in NetDocuments, it is likely that no versions of the documents have been successfully transferred.  

RESOLUTION:

You should review the logs related to document versions and correct any outstanding issues.

The most common cause is that the versions have a Final_Created_By or Final_Updated_By that is not in the __M_Users table or is and was not imported.  If this is your case, ensure that those fields are either blank or reference a user that was imported.

Once you have corrected any issues related to your document versions, you should run a script like this:
  1. UPDATE 
  2.     __M_Documents_Digital_Files
  3. SET
  4.     Action_Group = 6000
  5. WHERE 1=1
  6.     AND Result_Id != ''
  7.     AND Id IN (
  8.         SELECT
  9.             Final_DocumentFile_Id
  10.         FROM
  11.             __M_Documents_Digital_Files_Versions
  12.         WHERE 1=1
  13.             AND Result_Id = ''
  14.     )

So that all partially-imported documents have the highest Action_Group.
Once this is done, use Universal to tweak the documents.  Tweaking a document will cause Universal Migrator to re-attempt any versions for that document failed.


    • Related Articles

    • NetDocuments Restore: Importing Documents Seems Stuck with "A record is taking a long time"

      ISSUE: When importing documents into NetDocuments, uploading documents within folders seem to never complete and a message like the following is displayed: A record is taking a long time to process. This may be a big record or there may be an issue. ...
    • NetDocuments Data Restore: Read Me First

      Create Profile Attributes The Universal Migrator requires certain profile attributes to exist in NetDocuments. Please create the following Profile Attributes. Property Value Client Name Client Type Text Maximum Length 50 Use Lookup Table True Hide ...
    • NetDocuments: Copy Documents to Clio Document storage from Clio integration linked folders

      Clio has an integration with NetDocuments that creates folders in NetDocuments linked to Matters in Clio. If a client making use of this integration wants to move their documents from NetDocuments to being stored in Clio you can use this procedure. ...
    • NetDocuments: Preferred Permissions

      To export documents from NetDocuments as quickly as possible, the user doing the export should be a cabinet administrator. Follow the instructions below to set a user as a cabinet administrator. Setting a User as a Cabinet Administrator 1. Log into ...
    • NetDocuments: Disabling the Download Notification

      In NetDocuments, mass-downloading documents can trigger recurring email alerts to administrators. Update these settings as follows in order to avoid spamming your administrators. Disable the Notification Limit Log into NetDocuments and go to Admin: ...