ISSUE:
You appear to have successfully completed a migration into NetDocuments because all documents have a Result_Id and no error message. However, the documents are not visible or searchable in NetDocuments.
CAUSE:
The NetDocuments web interface does not list documents with no valid versions.
While the documents may have been successfully created in NetDocuments, it is likely that no versions of the documents have been successfully transferred.
RESOLUTION:
You should review the logs related to document versions and correct any outstanding issues.
The most common cause is that the versions have a Final_Created_By or Final_Updated_By that is not in the __M_Users table or is and was not imported. If this is your case, ensure that those fields are either blank or reference a user that was imported.
Once you have corrected any issues related to your document versions, you should run a script like this:
- UPDATE
- __M_Documents_Digital_Files
- SET
- Action_Group = 6000
- WHERE 1=1
- AND Result_Id != ''
- AND Id IN (
- SELECT
- Final_DocumentFile_Id
- FROM
- __M_Documents_Digital_Files_Versions
- WHERE 1=1
- AND Result_Id = ''
- )
So that all partially-imported documents have the highest Action_Group.
Once this is done, use Universal to tweak the documents. Tweaking a document will cause Universal Migrator to re-attempt any versions for that document failed.