NetDocuments Restore: Importing Documents Seems Stuck with "A record is taking a long time"

NetDocuments Restore: Importing Documents Seems Stuck with "A record is taking a long time"

ISSUE:

When importing documents into NetDocuments, uploading documents within folders seem to never complete and a message like the following is displayed:
  1. A record is taking a long time to process.
  2. This may be a big record or there may be an issue.

CAUSE:

This occurs when the user account that is importing documents does not have VESA permissions to the cabinet AND the relevant workspace.
To quickly check if you have the appropriate permissions, navigate to the workspace, click on the name of the workspace, and look at the "Add folder" options:
If it is clickable, you have the correct permissions for that workspace.  If it is greyed out, your permissions are not correct.

RESOLUTION:
Follow the instructions in this article and ensure you have the correct permissions.
Please note that if you have Workspace Security Manager (WSM) enabled, you may need to follow additional steps as WSM permissions can override global permissions.

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